Sycurio - PG secure Mode issue – Incident details

All systems operational

ℹ️ This status page reflects events impacting Sycurio services. Customer-specific incidents are managed and communicated directly. For security and compliance updates, visit our Trust Centre .

PG secure Mode issue

Resolved
Partial outage
Started 17 days agoLasted about 2 hours

Affected

Sycurio Data Centers

Partial outage from 12:19 PM to 1:58 PM

Sycurio UK Data Center 1 (London)

Partial outage from 12:19 PM to 1:58 PM

Updates
  • Resolved
    UTC
    Resolved

    The issue impacting London DC has been resolved and services are operating normally.

    We will continue to monitor closely and conduct a post-incident review.

    Thank you for your patience.

  • Identified
    UTC
    Identified

    We have identified an issue in the London DC, affecting a small number of merchants, which is preventing calls going into securemode. We are currently working on this and are hoping to get this sorted within the next hour or so