Sycurio - Sycurio US Data Center 1 (Boston) & Sycurio US Data Center 2 (Chicago) – incident identified – Incident details

All systems operational

ℹ️ This status page reflects events impacting Sycurio services. Customer-specific incidents are managed and communicated directly. For security and compliance updates, visit our Trust Centre .

Sycurio US Data Center 1 (Boston) & Sycurio US Data Center 2 (Chicago) – incident identified

Resolved
Major outage
Started about 1 month agoLasted 20 minutes
Updates
  • Resolved
    Resolved

    This incident has been resolved and services are restored.

  • Identified
    Identified

    We experienced a data Centre network issue that resulted in an outage Sycurio US Data Center 1 (Boston) & Sycurio US Data Center 2 (Chicago).

    Engineering teams are actively working on remediation.

    Some customers may experience degraded performance or intermittent errors during this time.

    Next update will be shared as progress is made.