ℹ️ This status page reflects events impacting Sycurio services.
Customer-specific incidents are managed and communicated directly.
For security and compliance updates, visit our
Trust Centre
.
Planned maintenance – UK DataCenter 2 (Manchester)
Completed
Scheduled for January 28, 2026 at 12:00 AM – 4:00 AM
Affects
Sycurio Data Centers
Under maintenance from 12:00 AM to 4:00 AM
Sycurio UK Data Center 2 (Manchester)
Under maintenance from 12:00 AM to 4:00 AM
Updates
Completed
January 28, 2026 at 4:00 AM
Completed
January 28, 2026 at 4:00 AM
Maintenance has completed successfully
In progress
January 28, 2026 at 12:00 AM
In progress
January 28, 2026 at 12:00 AM
Maintenance is now in progress
Planned
January 28, 2026 at 12:00 AM
Planned
January 28, 2026 at 12:00 AM
We will be performing scheduled maintenance on UK DataCenter 2 (Manchester) during this window.
Start time: 28 January 2025 - 00:00 (UTC)
End time: 28 January 2025 - 04:00 (UTC)
During this period, customers may experience brief service interruptions or degraded performance.