ℹ️ This status page reflects events impacting Sycurio services.
Customer-specific incidents are managed and communicated directly.
For security and compliance updates, visit our
Trust Centre
.
Planned maintenance – UK DataCenter 1 (London)
Completed
Scheduled for January 21, 2026 at 12:00 AM – 12:25 AM
Affects
Sycurio Data Centers
Under maintenance from 12:00 AM to 12:25 AM
Sycurio UK Data Center 1 (London)
Under maintenance from 12:00 AM to 12:25 AM
Updates
Completed
January 21, 2026 at 12:25 AM
Completed
January 21, 2026 at 12:25 AM
Planned maintenance on UK DataCenter 1 (London) has been completed successfully.
All services are operating normally and we will continue to monitor closely.
Thank you for your patience during this maintenance window.
Planned
January 21, 2026 at 12:00 AM
Planned
January 21, 2026 at 12:00 AM
We will be performing scheduled maintenance on UK DataCenter 1 (London) during this window.
Start time: 21 January 2026 - 00:00 (UTC)
End time: 21 January 2026 - 04:00 (UTC)
During this period, customers may experience brief service interruptions or degraded performance.
We will provide updates if anything changes.
In progress
January 20, 2026 at 11:56 PM
In progress
January 20, 2026 at 11:56 PM
Planned maintenance is currently in progress on UK DataCenter 1 (London).
Our engineering teams are actively carrying out the scheduled work.
Some customers may experience intermittent disruption during this time.
We will provide further updates as the maintenance progresses.